Camaro will not start, lost

I have a 2002 camaro, 5.3, ls6 intake, ls6 cam, 4l60e, 80lb siemens deka injectors, 3 bar OS.

Two weeks ago I got all the wiring hooked up and it was ready to start. I spent all day trying to figure out why it wouldn’t fire up. I realized the spark looked like it might be kind of weak. Finally, I noticed that there was a ground wire in the headlight harness near the passenger side headlight I hadn’t hooked back up. I grounded it to the body, and the car fired up almost right away, idled, leveled out, and ran well. I was really confused on why a ground there would even matter, but just went with it after a frustrating day of trying to get it going.

I started the car everyday for the following week for a few seconds at a time. Last Sunday I was about to install the intercooler and the charge piping, figured I would start the car, and it would not fire. It had the same exact symptoms as when the headlight harness ground wasn’t hooked up, but was still getting spark.

I could not get the car to start since then. When I crank it over, once every 20-30 seconds of cranking it gives a slight hope like it might fire up, but will never actually go. I posted my tune on HPtuners forum and a guy took a look at it and noticed some things I had wrong. I made those changes, but still will not fire up.

The fuel pump is coming on, there is fuel pressure at the little valve at the end of the fuel rail, I’ve check for spark on both banks, I’ve tried spraying starting fluid and fuel into the intake…nothing seems to change anything.

I’m really lost, the car was running well 2 weeks ago. Nothing changed that I’m aware of, and now it won’t fire. After the ground issue, I ran an additional ground from the battery, to the body, to the block, and nothing changed.

I’ve played around with the tune so much I don’t even remember which one I had in there when the car did start. But the one attached is copied over from someone on hptuners and should be a pretty good match for what I have in the car, but it still will not go.

I tried to upload the tune, but the forum would not allow the file; not sure if anyone on here uses HPtuners anyway. But if anyone knows what they’re doing and is willing to take a look I could email it.

Is it trying to run?
Do the plugs get wet/smell like fuel?

Didn’t know they made a 5.3 camaro. Or was it a V6 swap?

I haven’t pulled a plug after extensive cranking yet. The exhaust coming out of the turbo has a pretty strong fuel smell. It will give a hit of wanting to start once every 20-30 seconds of cranking. By that I mean, as it’s cranking it will kind of stumble and you will hear it fire once or twice, but that’s it. I will try pulling a plug after cranking tonight.

It’s a z28. Swapped in the iron block in place of the ls1.

Might sound silly but if you still have an EGR hooked up hit it with a hammer, maybe it’s stuck closed.

I would go back and double check all the other grounds.

That head light is on body BCM/harness and isn’t really related to the motor PCM wiring harness outside of VATS.

You should have to really screw the tune for it not to start is the crank sensor hooked up correctly?

Have you hooked up HP tuners and verified normal output from all the sensors when cranking?

Hopefully this gets resolved soon! :slight_smile:

Last night, engine temp was reading ~60, IAT ~70, TPS was reading, injector duty was 1-2% while cranking, everything seemed to be reporting as expected.

One thing I found this morning after doing a bit of reading, which I was not aware of before, was that there must be MAF failure codes set for it to run in SD. I have not verified that the MAF codes are actually failing prior to trying to start it. I will have to check that tonight. Perhaps it took a while for the code to fail last time, and that’s when it actually fired up?

Does it start/run on the starting fluid? If it does not, it’s still a spark or ignition related problem such as a crank angle sensor or just somthing simple such as weak spark

Map sensor and injectors scaled right?

Also I would check cam/crank

For your setup to get it just to run id pro flash in a stock tune and just scale the inj/map and go from there.

      • Updated - - -

I would say it sounds like ignition/ timing events as well.

I’d pull the plugs, clean or replace and have a friend spray some starter fluid in TB while your inside the car cranking and hitting the pedal. Having it start a few seconds a day has most fouled the plugs at this point if its really rich. Good luck.

Someone seemingly knowledgeable on hptuners forum gave me a base tune, all of the injector stuff matches what I was using. I had some DTC’s setup wrong.

I’m not sure about MAP scaling, I’ll have to take a look. But I believe that should all be good to go.

Is there a way to make sure the crank and cam sensors are reading properly? Do those display in the scanner? I’ll have to take a look when I get home.

Im not positive on checking the crank/cam. You didnt rewire the coils or anything right? Similar to this happened to me when I didnt have CRANKING power setup to either inj or spark i cant remember which.

      • Updated - - -

Start logging and if your kpa is around 95 with the car off you are setup right.

I had something like this happen when I was balls deep in a swap. Car started first time I ever attempted, drove it around my neighborhood, pulled it back in the garage and it NEVER started again. Had spark. Had fuel. Said FUCK CARS, sold it, and moved on. I highly encourage you to do the same. The air will seem a bit sweeter, the birds will sing just that one octave higher in the morning, and you too can be a happy person like me. Fuck cars, fuck all cars.

So I have confirmed I am not setting a code for MAF - P101, p102, p103, are all clear. From what I’ve read, the car will not go into SD until one of those codes is thrown. Sooooo, how do I get the car to throw one of those codes?? The maf cells in HPtuners are set to ‘0’ as instructed for SD.

This does make sense, the car took a long time to fire up the first time, it may have just taken it that long to disable the MAF. I think I remember putting the car on the charger the following week, which means the battery may have been dead enough to clear the code. After recharging, the car wouldn’t start because the MAF code was no longer there.

At least I REALLY hope.

will unplugging the maf cause the code? haha.

maybe find someone with a running vehicle that has the same maf and swap for a minute?

You don’t set the MAF cellS to 0 you set the fail frequency to 0 and disconnect it.

If you configure it correctly the MAF will fail instantly with key on.

      • Updated - - -

It’s something like p0103/p0101/p0102 set to fail on first


Engine Diag -> Airflow -> MAF Fail High -> Set to 0

The issue you’re probably having is you zeroed out the MAF table and then the MAF isn’t failing so the car has no idea what to do.

If it won’t run on starting fluid it’s likely not the MAF

I will have to check the maf table, but I’m pretty sure I left the values in there. I set the high rpm max, high rpm hyst, and MAF airmass filt all to zero, which I believe should be failing the maf…but I’m not getting the code. I will also have to check the maf fail high, I cannot remember what I had in there, but I’m assuming I also had that at 0.

The maf is not plugged in nor installed. It is just the open throttle body right now.