try to fix my vtec issue and come out with more problems... ahhhhf

so today i decided to pull my oil pan and see if pounding the dent out fixed anything of my vtec issue… it did not help, Also i cleaned the idle air control valve and reinstalled it… no fix, but now since i have done that my car runs like absolute asshole while warming up (1500rpm) until the rpm drops, and it runs like ass even when i am driving after it has warmed up but only at 1500 to like 1750 rpm. Now i also changed the coolant line routing. The line that goes from the head to the throttle body to the idle air control valve and back to the hard pipe on the back of the block… i looped it to bypass both the throttle body and iacv, Was it a bad thing to remove coolant flow to either the throttle body or the iacv? i had a jumpy idle after warming up before, now that is gone and has been replaced by this 1500rpm nonsense.


cleaned the screen on the vtec solenoid… both o them, they were not at all dirty, but cleaned them anyway.

Vtec Solenoid is working, i swapped in a oil pressure switch that i know is good. I THINK my oil pressure is good. any ideas? even on the 1500rpm issue?

for those who don’t know it’s a b18c turbo tuned on crome p28

The IAC will not work properly without coolant running through it which is why your idle is sparatic. I tried this as well because i didnt like the idea of 180 degree coolant warming up my intake charge. There are very minimal effects of not running the coolant. As for your vtec, is your coolant temp sensor working? If it is not working properly it will not engage into veeetak! Also make sure oil pressure is effecient and oil level is full.

just jump the oil pressure switch, its useless. take your vtec solenoid and put power to it and see if it clicks. If its working, you have an ecu/wiring problem. I dont think i’ve ever seen a total vtec failure due to actual mechanical failure.

Yeah you need the coolant lines to the iacv. usually people reroute them by bypassing the fitv on the throttle body but have it still go to the iacv. If you have surge till warmup its your fitv, if it all the time its the iacv. also adjust the screw on the throttle body if needed, for some reason mine needs to be all the way in or it will surge. I also blocked my fitv off from the back with a gasket since you only really need it here in the winter.

all coolant lines are now back to stock, and i still have the surging, but it is even when i drive from 1500-1750 or so rpm that it runs like ass, even when it is warm. the solenoid clicks, it is good, i’ll try jumping the oil switch. as for wiring, i know it’s all good, i did continuity tests on the wires to the vtec solenoid form the ecu and the oil pressure switch, but not all the others like tps, iacv, coolant temp, vss, and tach signal, but i have good signal to the tach, my speedo is working, and my coolant gauge is working, so i wouldn’t think it is those. I still want to check if it is the tps but i cannot get mine off of my integra because it has those dumb headless screws. i will have to dremel it but i cannot get to it so i need to pull the throttle body off and havn’t had time as it is my daily and i dont wanna f that one up too. thanks for the help guys, keep the ideas comin and i’ll keep you posted.

this has nothing to do with control…

I have came across this problem on a b16 and never figured it out…it just randomly started working…

I have another p28 we could try?

ok, so the issue with the 1500rpm thing was the wrong plug plugged into the iacv… still no vtec, but the idle air control valve is within spec and working.

fmfkid, i may have to make my way to your place sometime soon, when you gonna be around? i’d like to try a different ecu with my tune in it. Let me know via pm or whatever. I’ll swing by.

what was the iacv plugged into? if it was the iat, then that is toast… been there done that plenty of times fixing customer oops’s.

I’d also try swapping ecu’s, but defintily pull that tune down and re-check all the parameters to be sure.

his tuner sucked they are Def wrong

are you saying that my iat may be screwed? i plugged in a plug that has never been used on this engine from my d16z6 harness. with the same plug. anywho i probably need to try a different ecu… heck i don’t know anymore

have you thought about just replacing your VTEC? I have one for sale. PM me for info.

this is the most ridiculous thing anyone has ever said to me.

welcome to pittspeed

Maybe just control VTEC through a window switch…RPM activated. $30 - problem solved.

I thought you were putting it on the Vette? Wonder if the LS1 can handle it?

why? its just a couple of bolts. if the install is too much for you i could do it for you for a reasonable fee.

darkstar replaced my vtec, works perfectly now

fyi, not everybody takes BJ’s as payment…

well if you had said vtec solenoid that would make sense, however that is not my problem anyways, i know my solenoid is good, i’m not getting signal from my ecu to the solenoid, and it is not a wiring issue, it is something telling the ecu not to engauge vtec…

sorry, i just thought it was a funny way to put it that’s all, “replace your vtec”

maybe not funny to anyone else i dont know.

no it is not at all above my ability it has already been removed and reinstalled. thanks for the offer anyway

darkstar my car did not come with vtec orginally

can i get it installed and add the upgraded H feature

so i can have vtecH

which means i would be able to use my car as a portable phone as well